26th January 2019

London 3 (Maidenhead), UK Cloud London 3 connectivity issues

UPDATE #2 - Connectivity has been restored, services should now be accessible - Full RFO will be issued on Monday once the investigation concludes.

UPDATE #1 - Network fault identified, engineers on-site and working to address it asap.

We are currently investigating reports of connectivity issues at our London 3 Datacenter, we are liaising with DC staff to get the issue resolved as soon as possible, please standby for updates.