1st November 2019

Frankfurt, DE Cloud Frankfurt connectivity issues

UPDATE - Connectivity is restored, awaiting RCA from the DC.

UPDATE - DC staff working on the issue, whole DC affected, no ETA on a resolution currently.

We are currently investigating reports of connectivity issues at our Frankfurt Datacenter, we are liaising with DC staff to get the issue resolved as soon as possible, please standby for updates.