18th August 2020

London 2 (City), UK Cloud London 2 fault reported

We are currently investigating reports of downtime at our London 2 datacenter, please standby for updates.

UPDATE 13:33 - Connectivity has been restored and an official RFO will be provided accordingly

UPDATE 13:20 - DC teams are still working to restore service, we will post further updates as we have them

UPDATE 12:50 - DC teams are still working to restore service, we will post further updates as we have them

UPDATE 12:19 - DC teams are working to migrate power to new infrastructure

UPDATE 09:23 - Power fault identified, team on route to correct issue

UPDATE - Power fault identified at DC-Level, working with provider for updates.